程序化指标公式
问答中心

通达信私募能量顶底副图指标公式

通达信指标 2019-11-19阅读量:694

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

VAR0:=(2*CLOSE+HIGH+LOW)/4;
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
B:=EMA((VAR0-LLV(LOW,26))/(HHV(HIGH,34)-LLV(LOW,26))*100,16);
AA:=SMA(SMA(VAR2,2,1)+3,2,1),COLORRED,LINETHICK1;
浮筹:=EMA(B,4),LINETHICK1,DOTLINE,COLORYELLOW;
BB:=SMA(VAR1,3,1),COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0.02,0,0,'☆微信公众号:(程序化指标) ☆'),COLORRED;
{背景}
STICKLINE(AA>BB,10,90,5,0),COLOR000066;
STICKLINE(BB>AA,10,90,5,0),COLOR003300;
多方:SMA(SMA(VAR2,2,1)+3,2,1),COLORMAGENTA,LINETHICK2;
空方:SMA(VAR1,3,1),COLORGREEN,LINETHICK2;
强势线:90,COLORMAGENTA,DOTLINE;
中轴线: 50,COLORWHITE,DOTLINE;
弱势线:10,COLORLICYAN,DOTLINE;
STICKLINE(多方>强势线,多方,强势线,1,0),COLORRED;
STICKLINE(多方<弱势线,多方,弱势线,1,0),COLORRED;
STICKLINE(空方<弱势线,空方,弱势线,1,0),COLORGREEN;
STICKLINE(空方>强势线,空方,强势线,1,0),COLORGREEN;
STICKLINE(多方>浮筹,4,6,1,0),COLORRED;
STICKLINE(多方<浮筹,4,6,1,0),COLORGREEN;
{私募顶底}
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
见底:=10;
见顶:=90;
短期底部:=CROSS(趋势,见底),COLORRED;
STICKLINE(短期底部,4,40,1,0),COLORRED;
DRAWTEXT(CROSS(趋势,见底),40,'底');
短期顶部:=CROSS(见顶,趋势),COLORGREEN;
STICKLINE(短期顶部,4,40,1,0),COLORGREEN;
DRAWTEXT(CROSS(见顶,趋势),40,'顶'),COLORYELLOW;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭